Forum

General discussion about Bf Bot Manager v3 software for Betfair, Betdaq and Matchbook betting exchanges
By Casenova777
#25161
Hi Rade,

I'm testing something out but cant figure out why it wont trigger a bet? I edited the conditions to a point where i think it has to place it bet but it doesn't. What am I missing?

Thanks
Attachments
(3.54 KiB) Downloaded 16 times
User avatar
By BfBotManager
#25164
You should use strategy "Reports" tab to see which rule is preventing bet placement.

In your case "Selection conditions->Bet if specific..." rule is wrongly set as it is trying to check "WIN" market type selection for price range. There is no WIN market for football matches, maybe you wanted to check "MATCH_ODDS" market? WIN market type is used only for racing events.

Make sure OVER_UNDER_25 and MATCH_ODDS markets are loaded too to main MARKETS grid view if you are going to check price range at those markets.

Then test it in simulation mode.
By Casenova777
#25166
Thanks Rade. That has worked.

Another question please - I was also trying to add a rule to select games I pick for the bot to dutch the correct scores on. So instead of putting in market and selection conditions, I was looking at the selection conditions "My Selections" but then I'd have to put a check mark in each correct score runner position I wanted.
I want to pick the match, but then have the bot place the multiple bets. Any ideas?
User avatar
By BfBotManager
#25167
There is no option to pick the match.

Only solution is to use "Market conditions->Markets filter" rule and set it to allow markets whose name contains specific text e.g. Arsenal, Chelsea etc.
User avatar
By BfBotManager
#25168
Actually you can try following.

At MARKETS grid view display checkbox column "Back". Right click on main MARKETS grid view column header, then click on "Column chooser" and double click on "Back" item to add checkbox column "Back" to the main MARKETS grid view.

Then for your matches tick "Back" checkbox.

In your strategy, remove "Default bet type" and instead use "Market bet type" rule.

Then try again, it will only bet on matches for which you ticked "Back" checkbox. Attached are screenshots.
Attachments
Bet type by market 2.png
Bet type by market 2.png (31.66 KiB) Viewed 339 times
Bet type by market.png
Bet type by market.png (146.1 KiB) Viewed 339 times